GDB 7.12 32bit issue fix.
#1
Just wanted to let everyone who is currently using msys2 along with codelite or other IDE's that the 32bit version of GDB since version 7.12 has been broken. If you are using GDB 7.12 then you may want to downgrade to 7.11 as that is the current working edition of gdb with a GUI interface. If you are using Msys2 then this is pretty easy to do. You just need to make sure you always downgrade with each update you do unless they decide to fix gdb 32bit.

To do this you simply need to download this file:
http://repo.msys2.org/mingw/i686/mingw-w...pkg.tar.xz

Place that file in your msys2 home directory and then run this command:
Code:
pacman -U *.xz


It will ask you if you want to downgrade and you simply say yes. Once downgraded the 32bit version of gdb should now work on your IDE's. Just leave the file you downloaded in your home directory so you can then later use it if gdb still crashes for you when you update to a newer version of gdb.
Yours faithfully
Andrew Wheeler A.K.A Genusis

Ask Me For Help.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)